Windy's little blog

一切生活中的杂七杂八, and I like CTF.

使用kali linux的一些备忘录

以下基于kali linux 2020.41.安装discord在kali linux上安装discord会有依赖错误,其中有一个依赖需要按如下方法安装,kali linux自带仓库找不到。curl -p --insecure "http://ftp.br.debian.org/debian/pool/main/liba/libappindicator/libappindicator1_0.4.92-8_amd64.deb" --out

Pickle漏洞利用在python2和python3里有时不通用。

今天在玩HackMyVm的靶机Pickle的时候,遇到了这个问题,python3下pickle.dumps生成的payload代码,在靶机上总是显示进行md5 hash时,ascii编码出错。md5_encode = hashlib.md5(request.form["story"]).hexdigest()\nUnicodeEncodeError: 'ascii' codec can't e
<< 1 >>

Powered By Z-BlogPHP 1.7.0